Slow Response Times
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Jan 20, 2023 - 12:02 PST
Monitoring
A suspicious traffic pattern was identified and mitigated.
Posted Jan 20, 2023 - 09:12 PST
Investigating
We are currently investigating slow response times throughout the site
Posted Jan 20, 2023 - 08:52 PST
This incident affected: Substack publications, Writer dashboards, Email delivery, Subscription invoice processing, Substack.com, and Push Notifications.