Delays in activating custom domains
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 16:41 PDT
Identified
We are currently seeing delays in activating any new custom domains due to an outage with an external service provider. We are currently monitoring the issue.
Posted Nov 03, 2023 - 09:35 PDT