Publisher dashboards are unavailable
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 13:30 PDT
Monitoring
We have identified the issue and deployed a fix. We are continuing to monitor the issue.
Posted Oct 15, 2021 - 10:21 PDT
Investigating
We are currently investigating an issue preventing writers from accessing their publisher dashboards.
Posted Oct 15, 2021 - 10:16 PDT
This incident affected: Substack publications and Writer dashboards.