Issues Displaying Publisher Statistics
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 15:10 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 17, 2021 - 14:32 PDT
Investigating
We're aware of a problem in presenting usage stats to publishers. Engineers are working on resolving the problem.
Posted Sep 17, 2021 - 14:31 PDT
This incident affected: Writer dashboards.