Due to an outage with an upstream cloud service provider, Substack is currently unavailable. Our engineers are working to restore service as quickly as possible.

Incident Report for Substack

Resolved

This incident has been resolved.
Posted Aug 23, 2022 - 18:13 PDT

Investigating

We are currently investigating this issue.
Posted Aug 23, 2022 - 16:32 PDT
This incident affected: Substack publications, Writer dashboards, Email delivery, Subscription invoice processing, Substack.com, and Push Notifications.