Email analytics backup

Incident Report for Substack

Resolved

All email analytics should be up to date.
Posted May 01, 2025 - 18:21 PDT

Update

At this time, email delivery statistics are accurate, but we're still in the process of backfilling email open statistics between Tuesday and Wednesday afternoon.
Posted May 01, 2025 - 16:47 PDT

Update

Our engineers are backfilling missing data from the impacted time period. We'll continue to update the incident as that process completes.
Posted Apr 30, 2025 - 21:15 PDT

Identified

We have identified the issue related to delayed statistics for email deliveries and opens. We are currently processing enqueued events and working toward full recovery.
Posted Apr 30, 2025 - 07:21 PDT

Investigating

We are experiencing a delay in reader activity statistics relating to email deliveries/opens. Emails continue to send as normal, though their stats are currently delayed.
Posted Apr 30, 2025 - 06:31 PDT
This incident affected: Writer dashboards.