Web site slow to respond / intermittently unavailable
Incident Report for Substack
Resolved
Our CDN provider has implemented a fix, and all Substack web visits should be back to their usual (hopefully, snappy) performance.
Posted Feb 15, 2022 - 15:17 PST
Identified
Web visits to Substack publications may continue to be slow or intermittently available, as our CDN provider continues to work on problems in one of its primary West Coast data centers. We will update this page when things are fully back to normal.
Posted Feb 15, 2022 - 14:49 PST
Investigating
Substack is currently experiencing degraded network performance, which may be due to ongoing issues with our CDN provider. Visits to publication websites may be slow, or intermittently unavailable until this is resolved.
Posted Feb 15, 2022 - 11:04 PST
This incident affected: Substack publications, Writer dashboards, and Substack.com.