Duplicate Email Sends and Delayed Sends

Incident Report for Substack

Resolved

This incident has been resolved.
Posted Apr 08, 2022 - 18:34 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2022 - 17:04 PDT

Identified

Some publishers may observe that posts from the last two days have sent to their subscribers twice. Posts published in the last several hours are delayed as part of this incident. We have mitigated the issue and are implementing a long-term fix currently.
Posted Apr 08, 2022 - 16:58 PDT
This incident affected: Email delivery.