Substack experiencing increased latency

Incident Report for Substack

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 12:12 PDT

Monitoring

Substack is operating normally and our team is monitoring.
Posted Sep 15, 2025 - 11:39 PDT

Identified

We are seeing recurrence of increased error rates and degraded performance across Substack.
Posted Sep 15, 2025 - 10:43 PDT

Update

As part of the earlier incident, we are noting delays in analytics updating and post email delivery. We are working to resolve the issue.
Posted Sep 15, 2025 - 09:53 PDT

Monitoring

We are seeing recovery of performance across Substack and are monitoring the issue.
Posted Sep 15, 2025 - 09:46 PDT

Update

We are working to resolve the remaining performance issues across Substack and expect to see recovery shortly.
Posted Sep 15, 2025 - 09:38 PDT

Update

We are continuing to investigate increased latency and error rates across Substack.
Posted Sep 15, 2025 - 08:50 PDT

Identified

We have identified an issue and are seeing normal performance across all systems.
Posted Sep 15, 2025 - 08:42 PDT

Update

We are continuing to investigate increased latency and error rates across Substack.
Posted Sep 15, 2025 - 08:34 PDT

Investigating

We are currently investigating reports of increased latency and slow response times across Substack.
Posted Sep 15, 2025 - 08:24 PDT
This incident affected: Substack publications, Writer dashboards, Email delivery, Substack.com, and Custom domains.