Substack is experiencing issues
Incident Report for Substack
Resolved
The incident has been resolved
Posted Feb 26, 2024 - 12:22 PST
Investigating
We are currently investigating a degradation in Substack's service.
Posted Feb 26, 2024 - 12:11 PST
This incident affected: Substack publications, Writer dashboards, and Substack.com.