Substack emails failing to send
Incident Report for Substack
Resolved
This incident has been resolved, and emails should again be sending normally. Emails that failed to send during the outage are now being re-queued for delivery.
Posted Jun 08, 2021 - 19:32 PDT
Identified
We have identified an issue that is causing newsletter emails to fail to send, and are in the process of deploying a fix.
Posted Jun 08, 2021 - 17:30 PDT
This incident affected: Email delivery.