Mobile App Issues
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 14:32 PDT
Identified
We're working on remedying an issue causing many parts of the Substack iOS and Android apps to not load properly.
Posted Sep 18, 2024 - 14:19 PDT
This incident affected: Substack.com.