Issue loading some publisher dashboards
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Aug 24, 2023 - 11:17 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2023 - 11:11 PDT
Investigating
We have identified an issue loading some publisher dashboards and are working to restore functionality.
Posted Aug 24, 2023 - 10:54 PDT
This incident affected: Writer dashboards.