Substack Availability Issue

Incident Report for Substack

Update

Continuing to bring systems back online. Writer dashboard stats including open rates may be delayed or temporarily inaccurate.
Posted Jun 23, 2025 - 11:14 PDT

Monitoring

Restored functionality on Substack.com and app. We are continuing to work on a fix for some delays in email delivery.
Posted Jun 23, 2025 - 11:04 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2025 - 10:51 PDT

Investigating

We are currently investigating a higher error rate when trying to load Substack
Posted Jun 23, 2025 - 10:45 PDT
This incident affects: Substack publications, Writer dashboards, Email delivery, Subscription invoice processing, Substack.com, Push Notifications, and Custom domains.