Substack is experiencing a lot of traffic, impacting overall site performance.
Incident Report for Substack
Resolved
Substack's homepage is no longer experiencing downtime, and we are monitoring for further interruptions. We apologize for any inconvenience.
Posted Nov 15, 2022 - 18:10 PST
Monitoring
We are monitoring traffic to Substack.
Posted Nov 15, 2022 - 17:57 PST
Identified
We have identified the issue.
Posted Nov 15, 2022 - 17:49 PST
Investigating
We are currently investigating this issue.
Posted Nov 15, 2022 - 17:25 PST
This incident affected: Substack publications, Writer dashboards, and Substack.com.