Service degraded due to a provider.

Incident Report for Substack

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 13:48 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2026 - 12:45 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 22, 2026 - 12:36 PDT

Investigating

We are experiencing an issue with a provider.
Posted Apr 22, 2026 - 12:12 PDT
This incident affected: Substack publications, Writer dashboards, Email delivery, Subscription invoice processing, Substack.com, Push Notifications, and Custom domains.