Drafts not displaying on post dashboard
Incident Report for Substack
Resolved
This incident has been resolved.
Posted May 06, 2024 - 06:43 PDT
Investigating
We are currently investigating this issue.
Posted May 06, 2024 - 06:18 PDT
This incident affected: Writer dashboards.