Substack is down
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 12:33 PDT
Monitoring
Substack is back up. We are monitoring the issue.
Posted Sep 15, 2022 - 12:32 PDT
Investigating
We are currently investigating
Posted Sep 15, 2022 - 12:31 PDT
This incident affected: Substack publications, Writer dashboards, Email delivery, Substack.com, and Push Notifications.