Increased latency and error rate
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Feb 17, 2024 - 14:46 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2024 - 14:16 PST
Investigating
Substack is experiencing technical issues, we are investigating.
Posted Feb 17, 2024 - 13:15 PST
This incident affected: Substack publications, Writer dashboards, Email delivery, Subscription invoice processing, Substack.com, and Push Notifications.