Post emails delayed

Incident Report for Substack

Update

We continue to experience delays with processing scheduled posts related to an outage from one of our service providers. Users can publish posts manually to bypass this. Our team is still investigating.
Posted Oct 20, 2025 - 09:51 PDT

Identified

We are seeing recovery of our publisher dashboard functionality. Other service functions such as scheduled posts continue to be degraded.
Posted Oct 20, 2025 - 07:12 PDT

Update

We are also seeing issues with publication dashboards including partial outages across the subscriber tab and some statistics. We are working to mitigate.
Posted Oct 20, 2025 - 06:49 PDT

Investigating

We are experiencing delays with processing scheduled posts related to an outage from one of our service providers. Our team is investigating.
Posted Oct 20, 2025 - 06:41 PDT
This incident affects: Email delivery.