Substack is down
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Jul 15, 2021 - 10:08 PDT
Update
Substack is back up and we are monitoring the situation.
Posted Jul 15, 2021 - 07:28 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2021 - 07:28 PDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2021 - 06:53 PDT
Investigating
Substack is unavailable. We are investigating the issue.
Posted Jul 15, 2021 - 06:52 PDT
This incident affected: Substack publications, Writer dashboards, Email delivery, Subscription invoice processing, and Substack.com.