Substack site issues
Incident Report for Substack
Resolved
This issue has been resolved.
Posted Mar 15, 2024 - 14:00 PDT
Update
This issue has been resolved.
Posted Mar 15, 2024 - 13:59 PDT
Monitoring
We have resolved the issue and are continuing to monitor.
Posted Mar 15, 2024 - 13:55 PDT
Update
We are starting to see recovery and are continuing to work to resolve the issue.
Posted Mar 15, 2024 - 13:53 PDT
Identified
We have identified the issue and are working towards resolution.
Posted Mar 15, 2024 - 13:04 PDT
Update
We are continuing to investigate this issue.
Posted Mar 15, 2024 - 12:43 PDT
Investigating
We are currently investigating elevated latency across Substack.
Posted Mar 15, 2024 - 12:42 PDT
This incident affected: Substack publications, Writer dashboards, and Substack.com.