Post stats delayed
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 15:49 PDT
Monitoring
The issue has been resolved and post stats are no longer delayed.
Posted Mar 13, 2024 - 11:36 PDT
Identified
We have identified the issue and are working towards resolving the delay.
Posted Mar 13, 2024 - 10:28 PDT
Investigating
Substack is currently experiencing delays updating post metrics in writer dashboards. We are investigating this issue.
Posted Mar 13, 2024 - 09:40 PDT
This incident affected: Writer dashboards.