Substack is slow or unresponsive
Incident Report for Substack
Resolved
This incident has been resolved.
Posted May 06, 2021 - 09:39 PDT
Monitoring
A fix has been identified and released. We are monitoring the situation, but the Substack service should be back up.
Posted May 06, 2021 - 09:33 PDT
Investigating
Pages across substack.com are currently experiencing slow load times or are inaccessible. We are investigating the cause.
Posted May 06, 2021 - 08:33 PDT
This incident affected: Substack publications, Writer dashboards, and Substack.com.