Substack availability issues
Incident Report for Substack
Resolved
These issues have been resolved.
Posted Mar 12, 2024 - 11:06 PDT
Monitoring
The issue has been resolved and Substack is operating normally. We are continuing to monitor.
Posted Mar 12, 2024 - 10:06 PDT
Update
We have identified the issue and are working towards resolution.
Posted Mar 12, 2024 - 09:50 PDT
Update
We are continuing to investigate this issue.
Posted Mar 12, 2024 - 09:45 PDT
Update
We are continuing to investigate this issue.
Posted Mar 12, 2024 - 09:44 PDT
Investigating
We are investigating availability issues with Substack impacting editing tools and other dashboard functionality.
Posted Mar 12, 2024 - 09:25 PDT
This incident affected: Writer dashboards, Email delivery, Subscription invoice processing, and Push Notifications.