Increased latencies
Incident Report for Substack
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 15:18 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2024 - 14:48 PDT
Identified
We have identified the issue. Latency issues have been resolved and post stats on writer dashboards are currently catching up.
Posted Apr 08, 2024 - 11:20 PDT
Update
Some stats on writer dashboards may be delayed as we work to mitigate the issue.
Posted Apr 08, 2024 - 10:27 PDT
Investigating
We are currently investigating this issue.
Posted Apr 08, 2024 - 09:16 PDT
This incident affected: Substack publications, Writer dashboards, and Substack.com.